GPO ( Grupo de Profissionais Oracle )
A maior comunidade Oracle do Brasil !

Home Fóruns Developer,Designer e Discoverer IE 8.0 Forms 10g

Visualizando 15 posts - 1 até 15 (de 21 do total)
  • Autor
    Posts
  • #105863
    mpungan
    Participante

    olá Pessoal

    Não estou conseguindo executar forms no IE8. Estou rodando OCJ4 Instance conjuntamente. Já tentei o Chrome, Mozilla e até o Netscape, atualizei o Jinitator para a versão 1.3.1.25, já desabilitei conteúdos e atualizei o java tb. Uso windows7 32 bits. Se alguém souber alguma solução, agradeço.

    #105864

    Fala @mpugan !

    O que exatamente ocorre ? Trava o navegador ? Não aparece o forms ? O applet não inicia ?

    Qual a release exata do 10g que vocês usam ?
    Qual a versão do Java e do Jinitiator ?

    Houve alguma atualização desses componentes antes desse problema ?

    #105865
    mpungan
    Participante

    O que exatamente ocorre ? Trava o navegador ? Não aparece o forms ? O applet não inicia ?

    O que ocorre é que o navegador trava. O formas não aparece. O JInitiator esta ativado.

    Qual a release exata do 10g que vocês usam ?

    Forms [32 Bits] Versão 10.1.2.0.2 (Produção)
    Oracle Database 10g Enterprise Edition Release 10.2.0.5.0 – 64bit Production
    With the Partitioning, Real Application Clusters, OLAP, Data Mining
    and Real Application Testing options
    Oracle Toolkit Versão 10.1.2.0.2 (Produção)
    Versão 10.1.0.4.2 (Produção) de PL/SQL
    Oracle Procedure Builder V10.1.2.0.2 – Production
    PL/SQL Editor (c) WinMain Software (http://www.winmain.com), v1.0 (Production)
    Oracle Query Builder 10.1.2.0.2 – Production
    Oracle Virtual Graphics System Versão 10.1.2.0.2 (Produção)
    Oracle Tools GUI Utilities Versão 10.1.2.0.2 (Produção)
    Oracle Multimedia Versão 10.1.2.0.2 (Produção)
    Oracle Tools Integration Versão 10.1.2.0.2 (Produção)
    Oracle Tools Common Area Version10.1.2.0.2
    Oracle CORE 10.1.0.4.0 Production

    Qual a versão do Java e do Jinitiator ?
    1.3.1.22

    Houve alguma atualização desses componentes antes desse problema ?
    Não. Foi uma instalação limpa. Instalação do zero.

    #105866

    Dá uma olhada nessas linhas no arquivo formsweb.cfg

    # Page displayed to users to allow them to download Sun’s Java Plugin.
    # Sun’s Java Plugin is typically used for non-Windows clients.
    # (NOTE: you should check this page and possibly change the settings)
    jpi_download_page=http://java.sun.com/products/archive/j2se/1.4.2_06/index.html
    # Parameter related to the version of the Java Plugin
    jpi_classid=clsid:CAFEEFAC-0014-0002-0006-ABCDEFFEDCBA
    # Parameter related to the version of the Java Plugin
    jpi_codebase=http://java.sun.com/products/plugin/autodl/jinstall-1_4_2-windows-i586.cab#Version=1,4,2,06
    # Parameter related to the version of the Java Plugin
    jpi_mimetype=application/x-java-applet;jpi-version=1.4.2_06
    # EM config parameter
    # Set this to “1” to enable Enterprise Manager to track Forms processes
    em_mode=0

    Ele tem que estar de acordo com a versão do jinitiator e do java instalados.

    #105868
    mpungan
    Participante

    Essa configurações que vc passou estão batendo com as minhas, talvez como minha máquina esta com muita coisa instalada seja por conta disso. Segunda-feira, vou fazer uma máquina nova, uma máquina limpa e instalar tudo novamente para testar. Por enquanto obrigado pela ajuda.

    Mpungan

    #105869

    Depois da uma olhada nesse artigo:

    http://windows7bugs.wordpress.com/2012/ … initiator/

    Ele mostra como rodar o forms sem esse lixo do Jinitiator. Fiz no meu computador em casa e funcionou.

    Com certeza isso vai te poupar muitos problemas ! 🙂

    Não esqueça de dar um feedback depois !

    Abraço

    #105876
    mpungan
    Participante

    O Forms 10g vai rodar no IE 10 ou em outras versões mais anteriores? Tipo 9, 8 ou 7?

    Att.

    Mpungan

    #105880

    @mpungan

    No internet explorer 7 e 8 é certeza que roda !
    Sei de gente que já executou no 10, mas não vi pessoalmente isso.

    #105882
    mpungan
    Participante

    Quando abro o forms da o erro abaixo:

    FRM-10102: Não é possível anexar bibliotecas PL/SQL LIB_ACV. Essa anexação de biblioteca será perdida se o módulo for salvo.
    Ai vou compilar e da erro e trava o forms, e não rola. Não tenho muito idéia do que é, porque sou DBA e estou tentando quebrar um galho para ver se um sistema que esta sendo executado em Oracle 8i rodando em forms 5. Ve se conseguimos migrar para Oracle 10g e Forms 10, mas não esta nada fácil. A empresa que fez o sistema não existe mais e case ninguém sabe mexer nos fontes. Ai estou tentanto fazer o possível para ver se migramos isso.

    Mpungan

    #105892

    @mpungan

    Você precisa colocar na variável FORMS_PATH o caminho de onde estão as bibliotecas. Sem isso ele não compila mesmo se tiver qualquer coisa referenciada no forms.

    Vai la no prompt do Windows e da um set na mão para testar.

    #105903
    mpungan
    Participante

    O FORMS_PATH esta conforme abaixo:

    FORMS_PATH=C:DevSuiteHome_1cgenf61admin;C:DevSuiteHome_1forms

    #105904

    @mpungan

    Os objetos que nos quais o FORMS está reclamando na hora de compilar, se encontram em alguma dessas pastas ?

    #105907
    mpungan
    Participante

    Blz, tua dica funcionou, coloquei o caminho onde estão os arquivos PLL, e pelo forms builder consigo compilar, mas porém não gera o PLX. Mas descobri que para gerar os arquivos PLX, tem que complicar por linha de comando. Estou usando o comando abaixo, mas não esta gerando os arquivos PLX. Gostaria de saber se o comando esta correto para compilar os arquivo PLL no Developer 10g.

    frmcmp userid=user/senha@serv1 module=LIB_ACV.pll module_type=library compile_all=yes window_state=minimize

    Usei o comando abaixo para compilar os forms e funcionou.
    frmcmp userid=user/senha@serv1 module=AGE0000.fmb module_type=form compile_all=yes window_state=minimize

    #105908

    @mpungan

    Vamos resolvendo parte a parte.

    frmcmp userid=scott/tiger@bs817 batch=no module=LIB_ACV.pll module_type=LIBRARY

    Isso já deve adiantar. O batch está como no por que estamos compilando apenas um.

    Se não estiver rodando do diretório onde está a PLL, você deve indicar o path junto com o nome.

    Testa aí. Se der alguma mensagem, envie para avaliarmos !

    #105909
    mpungan
    Participante

    Quando executei o comando abaixo:

    frmcmp userid=user/user@racdes batch=no module=LIB_ACV.pll module_type=LIBRARY

    A primeira mensagem que deu foi essa abaixo:

    FRM-30312: Falha na compilação da biblioteca.

    A segunda foi para verificar o arquivo LIB_ACV.err

    Z:>type LIB_ACV.err
    FRM-30312: Falha na compilaþÒo da biblioteca.

Visualizando 15 posts - 1 até 15 (de 21 do total)
  • Você deve fazer login para responder a este tópico.