Pular para o conteúdo
  • Este tópico contém 10 respostas, 2 vozes e foi atualizado pela última vez 11 anos atrás por Avatar de JulianJulian.
Visualizando 11 posts - 1 até 11 (de 11 do total)
  • Autor
    Posts
  • #105671
    Avatar de JulianJulian
    Participante

      Seguinte fui fazer backup rman e recebi um erro dizendo que meu archivelog está
      desativado,

      coloquei então no init.ora que criei o seguinte comando :
      CPU_COUNT=4
      LOG_ARCHIVE_START=TRUE

      porém o archive log ainda consta como noarchivelog :

      SQL> select log_mode from v$database;

      LOG_MODE
      ————
      NOARCHIVELOG

      já reiniciei o serviceOracle e o servidor e nada, alguem pdoe me ajudar.

      já tentei também está dica : http://aprenderoracle.com/2011/07/habil … racle-11g/

      na 2· parte (startup mount) dá um erro aqui e não consigo subir o banco em mount.

      #105673
      Avatar de rmanrman
      Participante

        @juliansoares

        A mudança que você fez no init.ora não faz parte do processo de habilitar o ARCHIVELOG.

        Qual o erro apresentado?

        #105674
        Avatar de JulianJulian
        Participante

          RMAN> BACKUP DATABASE PLUS ARCHIVELOG FORMAT “c:backupbackup_%U”;

          Iniciando backup em 18/07/13
          Erro do ORACLE no banco de dados de destino:
          ORA-00258: o arquivamento manual no modo NOARCHIVELOG deve identificar o log

          usar o arquivo de controle do banco de dados de destino em vez do catßlogo de re
          cuperaþÒo
          canal alocado: ORA_DISK_1
          canal ORA_DISK_1: SID=132 tipo de dispositivo=DISK
          a especificaþÒo nÒo corresponde a nenhum log arquivado no reposit¾rio
          backup cancelado porque nÒo hß arquivos a serem submetidos a backup
          Finalizado backup em 18/07/13

          Iniciando backup em 18/07/13
          utilizando o canal ORA_DISK_1
          canal ORA_DISK_1: iniciando conjunto de backup completo de arquivo de dados
          canal ORA_DISK_1: especificando arquivo(s) de dados no conjunto de backups
          RMAN-03009: falha do comando backup no canal de ORA_DISK_1 em 07/18/2013 13:18:0
          7
          ORA-19602: nÒo pode copiar ou fazer backup de arquivo ativo no modo NOARCHIVELOG

          continuando outras etapas do job; job com falha nÒo serß executado novamente
          canal ORA_DISK_1: iniciando conjunto de backup completo de arquivo de dados
          canal ORA_DISK_1: especificando arquivo(s) de dados no conjunto de backups
          incluindo arquivo de controle atual no conjunto de backups
          incluindo SPFILE atual do conjunto de backups
          canal ORA_DISK_1: iniciando o componente 1 em 18/07/13
          canal ORA_DISK_1: componente 1 finalizado em 18/07/13
          handle de componente=D:APPFAST_RECOVERY_AREACFLEXBACKUPSET2013_07_18O1_MF_
          NCSNF_TAG20130718T131806_8YJ5C81Y_.BKP tag=TAG20130718T131806 comentßrio=NONE
          canal ORA_DISK_1: conjunto de backups concluÝdo, tempo decorrido: 00:00:04
          RMAN-00571: ===========================================================
          RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
          RMAN-00571: ===========================================================
          RMAN-03002: falha do comando backup plus archivelog em 07/18/2013 13:18:51

          RMAN-03009: falha do comando backup no canal de ORA_DISK_1 em 07/18/2013 13:18:0
          7
          ORA-19602: nÒo pode copiar ou fazer backup de arquivo ativo no modo NOARCHIVELOG

          SQL> select log_mode from v$database;

          LOG_MODE

          NOARCHIVELOG

          já tentei :

          shutdown immediate
          startup mount -> ai da eerro nesse cara e não consigo subir mais o banco p fazer o resto dos comandos
          alter database archivelog
          alter database open

          SQL> shutdown immediate;
          Banco de dados fechado.
          Banco de dados desmontado.
          InstÔncia ORACLE desativada.
          SQL> startup mount;
          ORA-12514: TNS:listener nÒo tem conhecimento sobre o serviþo solicitado atualmen
          te no descritor de conexÒo
          SQL> startup mount;
          ORA-24324: handle de serviþos nÒo inicializado
          ORA-01041: erro interno: a extensÒo hostdef nÒo existe
          SQL>

          #105675
          Avatar de rmanrman
          Participante

            @juliansoares

            Talvez o problema está no listener.

            Poste os resultados dos comandos:


            lsnrctl status
            lsnrctl services

            #105676
            Avatar de JulianJulian
            Participante

              STATUS do LISTENER

              Apelido CFLEX
              VersÒo TNSLSNR for 64-bit Windows: Version 11.2.0.3.0 – Produ
              ction
              Data Inicial 18-JUL-2013 13:26:58
              Funcionamento 0 dias 0 hr. 37 min. 50 seg
              NÝvel de Anßlise off
              Seguranþa ON: Local OS Authentication
              SNMP OFF
              Arq. ParÔm. Listn. D:appproduct11.2.0dbhome_1networkadminlistener.ora
              Arq. Log Listener D:appdiagtnslsnrvmmegacflexalertlog.xml
              Resumo de Atendimento…
              (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=vmmega)(PORT=1521)))
              (DESCRIPTION=(ADDRESS=(PROTOCOL=ipc)(PIPENAME=.pipeEXTPROC1521ipc)))
              Resumo de Serviþos…
              O serviþo “CFLEXXDB” tem 1 instÔncia(s).
              InstÔncia “cflex”, status READY, tem 1 handler(s) para este serviþo…
              O serviþo “CLRExtProc” tem 1 instÔncia(s).
              InstÔncia “CLRExtProc”, status UNKNOWN, tem 1 handler(s) para este serviþo…
              O serviþo “cflex” tem 1 instÔncia(s).
              InstÔncia “cflex”, status READY, tem 1 handler(s) para este serviþo…
              O comando foi executado com Ûxito

              C:UsersAdministrator>lsnrctl services

              LSNRCTL for 64-bit Windows: Version 11.2.0.3.0 – Production on 18-JUL-2013 14:05
              :13

              Copyright (c) 1991, 2011, Oracle. All rights reserved.

              Estabelecendo conexÒo com (ADDRESS=(PROTOCOL=tcp)(HOST=)(PORT=1521))
              Resumo de Serviþos…
              O serviþo “CFLEXXDB” tem 1 instÔncia(s).
              InstÔncia “cflex”, status READY, tem 1 handler(s) para este serviþo…
              Handler(s):
              “D000” estabelecido:0 recusado:0 atual:0 mßx.:1022 estado:ready
              DISPATCHER
              (ADDRESS=(PROTOCOL=tcp)(HOST=vmmega)(PORT=49160))
              O serviþo “CLRExtProc” tem 1 instÔncia(s).
              InstÔncia “CLRExtProc”, status UNKNOWN, tem 1 handler(s) para este serviþo…
              Handler(s):
              “DEDICATED” estabelecido:0 recusado:0
              LOCAL SERVER
              O serviþo “cflex” tem 1 instÔncia(s).
              InstÔncia “cflex”, status READY, tem 1 handler(s) para este serviþo…
              Handler(s):
              “DEDICATED” estabelecido:0 recusado:0 estado:ready
              LOCAL SERVER
              O comando foi executado com Ûxito

              #105677
              Avatar de rmanrman
              Participante

                @juliansoares

                Tente da seguinte forma:


                SQL> shutdown immediate;
                SQL> startup;
                SQL> alter system register;
                SQL> shutdown immediate;
                SQL> startup mount;

                #105678
                Avatar de JulianJulian
                Participante

                  [quote=”rman”:32ilxrp1]@juliansoares

                  Tente da seguinte forma:


                  SQL> shutdown immediate;
                  SQL> startup;
                  SQL> alter system register;
                  SQL> shutdown immediate;
                  SQL> startup mount;
                  [/quote]
                  Não passa do startup!

                  SQL> startup;
                  ORA-24324: handle de serviþos nÒo inicializado
                  ORA-01041: erro interno: a extensÒo hostdef nÒo existe

                  #105679
                  Avatar de rmanrman
                  Participante

                    @juliansoares

                    Reinicie a máquina e tente novamente.

                    #105680
                    Avatar de JulianJulian
                    Participante

                      [quote=”rman”:q8fkospa]@juliansoares

                      Reinicie a máquina e tente novamente.[/quote]
                      já reiniciei, dai o oracle starta, faça o shutdown novamente e dps o startup não vai .

                      #105681
                      Avatar de rmanrman
                      Participante

                        @juliansoares

                        Verifique o alert.log

                        #105682
                        Avatar de JulianJulian
                        Participante

                          [quote=”rman”:3bqala97]@juliansoares

                          Verifique o alert.log[/quote]
                          Não tem alert.log no sistema.

                        Visualizando 11 posts - 1 até 11 (de 11 do total)
                        • Você deve fazer login para responder a este tópico.
                        plugins premium WordPress