Pular para o conteúdo
  • Este tópico contém 3 respostas, 2 vozes e foi atualizado pela última vez 10 anos atrás por Avatar de Andrei RubinoAndrei Rubino.
Visualizando 4 posts - 1 até 4 (de 4 do total)
  • Autor
    Posts
  • #106351
    Avatar de Andrei RubinoAndrei Rubino
    Participante

      Olá Pessoal,
      Instalei recentemente o Oracle 12c em um Windows Server 2012.
      A instalação funcionou tudo Ok.
      Porém estou com o seguinte problema, ao conectar via sqlplus ele exibe a mensagem
      Conectada a uma instancia Inativa.
      E ao conectar pelo SQL Developer ele da o ORA-12541: TNS:no listener.

      Os serviços estão rodando normalmente.
      Se eu conectar via sqlplus e dar um startup ele funciona normalmente !
      Porém toda vez que reiniciar o servidor vou ter que fazer isso no braço ?

      Segue os dados do LISTENER E TNSNAME.
      ———————–TNSNAME——————–

      BETAVIGIA =
      (DESCRIPTION =
      (ADDRESS = (PROTOCOL = TCP)(HOST = BETA-SOLUTIONS.betasolutions.com.br)(PORT = 1521))
      (CONNECT_DATA =
      (SERVER = DEDICATED)
      (SERVICE_NAME = BETAVIGIA)
      )
      )

      ———————–LISTENER——————

      LISTENER =
      (DESCRIPTION_LIST =
      (DESCRIPTION =
      (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1521))
      (ADDRESS = (PROTOCOL = TCP)(HOST = BETA-SOLUTIONS.betasolutions.com.br)(PORT = 1521))
      )
      )

      Alguém pode me ajudar ?
      Obrigado !

      #106352
      Avatar de rmanrman
      Participante

        @Andrei

        Ainda não tive a oportunidade de instalar o Oracle 12c e em ambiente Windows eu trabalhei muito pouco, mas lembro que para o Oracle 11g no Windows existem serviços da instância e do listener.

        Verifique no serviços se eles estão configurados para iniciar automaticamente.

        #106353
        Avatar de Andrei RubinoAndrei Rubino
        Participante

          @rman

          Então cara, tem sim.Todos estão configurados para iniciar automaticamente ….
          Logo após reiniciar o servidor:
          Ao executar o comando lsnrctl start, ele diz que já foi iniciado.
          Ao executar o STATUS, ele diz o LISTENER não aceita Serviços.

          Ai então eu conecto com o SYS e do o STARTUP na base.
          Executo o comando STATUS, ai sim ele me traz os serviços e as instancias !

          Alguma dica ?
          Procurei bastante na net, encontrei varios exemplos, mas nao consegui resolver ainda…

          #106358
          Avatar de Andrei RubinoAndrei Rubino
          Participante

            Resolvi criando uma tarefa para executar um .bat, para não ter que fazer isso manual …

          Visualizando 4 posts - 1 até 4 (de 4 do total)
          • Você deve fazer login para responder a este tópico.
          plugins premium WordPress